Besøgende
Gæster online: 10
Brugere online: 0
Antal brugere: 1,720
Nyeste bruger: thomaslarsen
10 nyeste brugere: Klik her
 42,279,050 Unikke besøg
10164 Besøg pr. dag
Synes godt om
Translate this page
Tilfældige Avatars
388 brugere (22.65%)
Har allerede en Avatar.
Artikler
Nyeste artikler
V7 versions-liste 15515
V6/V7-identifier 20450
Tilfældigt tema på ... 15738
Hvordan tælles unik... 16825
Ens registreringssi... 196389
Populære artikler
Ens registreringssi... 196389
Kør PHP-Fusion loka... 39513
Tilfældigt banner/l... 30784
Flytning af PHP-Fus... 29546
Opgradering af PHP-... 25000
Info om artikler
Artikler i databasen: 9
Læst antal gange: 389760
Downloads
Nyeste downloads
Danske sprogfiler ... 410
Avatar in viewforu... 897
Latest Blacklisted... 891
Search in Shouts 849
Users Websites Pan... 824
Populære downloads
DeLuxe Dropdown Me... 3766
CSS Dropdown Menu ... 2715
Installations-vide... 2559
PHP-Fusion v7.00.0... 2475
Forum Pack v1.0 2183
Info om downloads
Filer i databasen: 180
Hentet antal gange: 125684
Statistik mm.
Se indlæg
PHPFusion-Tips.dk :: PHP-Fusion v7.02.XX :: Generel debat
Hvem er her? 1 gæst(er)
 Udskriv debat
Unoeuro, fejl ved ny installation
ju_dk
#1 Udskriv indlæg
Lagt på d. 08-11-2017 19:15
Brugers avatar

Super Administrator


Antal indlæg: 1293
Tilmeldt: 25.04.08
Sidst set: 13.06.19
On/Offline: Offline
Status:
Jeg er ikke SMOKEMAN, derfor må brugere godt hjælpe hinanden. :-)
Dagens humør:

 
Nu jeg stødt ind i et problem, som jeg ikke har set før.

Web10 / Talk Active er blevet opkøbt af unoeuro
og alle ting er flyttet over på deres server som køre PHP 7.0 og MySQL 5.7.19-17

Den tidligere v7.01.XX begyndte at vise fejl som denne
Deprecated: preg_replace() [function.preg-replace]: The /e modifier is deprecated, use preg_replace_callback instead in /var/www/test.phpfusion-tips.dk/public_html/includes/bbcodes/url_bbcode_include.php on line 21

Denne kode kan henvises til at det er PHP 7.0 som er årsagen,
det fungere nemlig på anden server med PHP 5.6 MyQSL 5.6.34-1 uden problemer.

Nu var det jo ikke dette problem som jeg lige ville løse,
men at jeg har lagt en helt ny installation af V7.02.05 op på unoeuro,s server

Under installationen Trin 3: Databaseopsætning kan setup.php ikke oprette databasen under punkt 4 og kommer med fejl.

Trin 4: Opsætning af konfigurationsfil og database

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /var/www/test.phpfusion-tips.dk/setup.php:214 Stack trace: #0 {main} thrown in /var/www/test.phpfusion-tips.dk/setup.php on line 214


line 214 ser sådan ud (kun udsnit)
Download kildekode  Kode
if ($db_host != "" && $db_user != "" && $db_name != "" && $db_prefix != "") {
      $db_connect = @mysql_connect($db_host, $db_user, $db_pass);
      if ($db_connect) {
         $db_select = @mysql_select_db($db_name);
         if ($db_select) {
            if (dbrows(dbquery("SHOW TABLES LIKE '".str_replace("_", "\_", $db_prefix)."%'")) == "0") {
               $table_name = uniqid($db_prefix, false); $can_write = true;
               $result = dbquery("CREATE TABLE ".$table_name." (test_field VARCHAR(10) NOT NULL) ENGINE=MYISAM;");
               if (!$result) { $can_write = false; }
               $result = dbquery("DROP TABLE ".$table_name);
               if (!$result) { $can_write = false; }
               if ($can_write) {
                  $config = "<?php\n";
                  $config .= "// database settings\n";
                  $config .= "\$db_host = \"".$db_host."\";\n";
                  $config .= "\$db_user = \"".$db_user."\";\n";
                  $config .= "\$db_pass = \"".$db_pass."\";\n";
                  $config .= "\$db_name = \"".$db_name."\";\n";
                  $config .= "\$db_prefix = \"".$db_prefix."\";\n";
                  $config .= "define(\"DB_PREFIX\", \"".$db_prefix."\");\n";
                  $config .= "define(\"COOKIE_PREFIX\", \"".$cookie_prefix."\");\n";
                  $config .= "?>";
                  $temp = fopen("config.php","w");
                  if (fwrite($temp, $config)) {
                     fclose($temp);
                     $fail = false;
                     $result = dbquery("DROP TABLE IF EXISTS ".$db_prefix."admin");
                     $result = dbquery("CREATE TABLE ".$db_prefix."admin (
                     admin_id MEDIUMINT(8) UNSIGNED NOT NULL AUTO_INCREMENT,
                     admin_rights CHAR(4) NOT NULL DEFAULT '',
                     admin_image VARCHAR(50) NOT NULL DEFAULT '',
                     admin_title VARCHAR(50) NOT NULL DEFAULT '',
                     admin_link VARCHAR(100) NOT NULL DEFAULT 'reserved',
                     admin_page TINYINT(1) UNSIGNED NOT NULL DEFAULT '1',
                     PRIMARY KEY (admin_id)
                     ) ENGINE=MYISAM;");




nu har jeg ikke taget hele "if" sætningen med da den kommer med fejlen ved starten.

Er der andre der har prøvet at få sådan en fejl under installation.

Edit: kan nu se at det har været samme fejl langt tilbage
og der var der heller ikke nogen tilbagemelding om der var en løsning.
se her http://www.phpfus...ad_id=6401
Redigeret af ju_dk d. 08-11-2017 19:24



Mvh
ju_dk

phpfusion-tips.dk/signaturer/ju_dk.png
Til forsiden  Til toppen af forum  Til bunden af forum
ejvindh
#2 Udskriv indlæg
Lagt på d. 20-12-2017 09:42
Standart Avatar

Bruger


Antal indlæg: 28
Tilmeldt: 07.06.13
Sidst set: 29.01.19
On/Offline: Offline
Status:
Ingen status er valgt
Dagens humør:
Ikke valgt
 
Har du prøvet dette råd:
http://php-fusion.dk/forum/viewthread.php?thread_id=19322
Til forsiden  Til toppen af forum  Til bunden af forum
ju_dk
#3 Udskriv indlæg
Lagt på d. 20-12-2017 10:33
Brugers avatar

Super Administrator


Antal indlæg: 1293
Tilmeldt: 25.04.08
Sidst set: 13.06.19
On/Offline: Offline
Status:
Jeg er ikke SMOKEMAN, derfor må brugere godt hjælpe hinanden. :-)
Dagens humør:

 
Tak for tippet, desværre virkede det ikke.

Fejlen ligger stadig i forumet og kommentar felt.



Mvh
ju_dk

phpfusion-tips.dk/signaturer/ju_dk.png
Til forsiden  Til toppen af forum  Til bunden af forum
ejvindh
#4 Udskriv indlæg
Lagt på d. 20-12-2017 11:14
Standart Avatar

Bruger


Antal indlæg: 28
Tilmeldt: 07.06.13
Sidst set: 29.01.19
On/Offline: Offline
Status:
Ingen status er valgt
Dagens humør:
Ikke valgt
 
Måske denne kan hjælpe dig:
https://www.php-fusion.co.uk/forum/viewthread.php?thread_id=37910&pid=203384#post_203384

...ellers tænker jeg, at det bedste råd kan være at nedgradere php-versionen på din server, indtil der kommer en stabil fusion9-udgave. Det handler nemlig om, at den seneste udgave af php-fusion7 bruger nogle php-kommandoer, som ikke understøttes i de seneste udgaver af php.
Redigeret af ejvindh d. 20-12-2017 11:17
Til forsiden  Til toppen af forum  Til bunden af forum
ju_dk
#5 Udskriv indlæg
Lagt på d. 21-12-2017 11:46
Brugers avatar

Super Administrator


Antal indlæg: 1293
Tilmeldt: 25.04.08
Sidst set: 13.06.19
On/Offline: Offline
Status:
Jeg er ikke SMOKEMAN, derfor må brugere godt hjælpe hinanden. :-)
Dagens humør:

 
Det virker hvis kun ved en opgradering

Unoeuro tilbyder ikke mulighed for nedgradering af php version,
heldigvis findes der andre der gør dette, så det bliver nok skift af Host.

Når V9 er stabil, så er jeg med.



Mvh
ju_dk

phpfusion-tips.dk/signaturer/ju_dk.png
Til forsiden  Til toppen af forum  Til bunden af forum
ejvindh
#6 Udskriv indlæg
Lagt på d. 21-12-2017 12:46
Standart Avatar

Bruger


Antal indlæg: 28
Tilmeldt: 07.06.13
Sidst set: 29.01.19
On/Offline: Offline
Status:
Ingen status er valgt
Dagens humør:
Ikke valgt
 
Det er nu ikke helt rigtigt. Den indeholder både en fuld 7.2.07 (men altså tilføjet de nævnte fixes) (i mappen: [full]), og så kan man også vælge (hvis man allerede har installeret 7.2.07) bare at bruge update mappen.

Det eneste du skal tænke på (som jeg forstår det) er at få lagt en dansk lokalfil ind, da den kun indeholder den engelske og tyske.

Men ja, det er naturligvis også en mulighed at skifte host Smile
Til forsiden  Til toppen af forum  Til bunden af forum
marie_e
#7 Udskriv indlæg
Lagt på d. 28-11-2018 22:21
Standart Avatar

Junior bruger


Antal indlæg: 1
Tilmeldt: 28.11.18
Sidst set: 28.11.18
On/Offline: Offline
Status:
Ingen status er valgt
Dagens humør:
Ikke valgt
 
Det er vidst muligt at nedgradere til PHP version 5.6
https://www.unoeu...faq/php/1/

Jeg mener dog at den funktion måske udgår i december, men jeg er ikke sikker.



Ejer af: https://dingavegu...
Til forsiden  Til toppen af forum  Til bunden af forum
https://dingaveguide.dk/
ejvindh
#8 Udskriv indlæg
Lagt på d. 29-01-2019 11:27
Standart Avatar

Bruger


Antal indlæg: 28
Tilmeldt: 07.06.13
Sidst set: 29.01.19
On/Offline: Offline
Status:
Ingen status er valgt
Dagens humør:
Ikke valgt
 
Løsningen er at opgradere til v8, som er en "konservativ" upgrade, der netop skal håndtere at v7 ikke er kompatibel med php7:

http://php-fusion.dk/news.php?readmore=504
http://php-fusion.dk/news.php?readmore=505
http://php-fusion.dk/news.php?readmore=506
https://www.php-fusion.co.uk/infusions/news/news.php?readmore=624
Til forsiden  Til toppen af forum  Til bunden af forum
Spring til debat:
 
Lignende tråde
Debat Forum Svar Nyeste indlæg
Fejl Generel debat 6 10-03-2016 15:19
Fejl under instal. Generel debat 2 09-03-2016 23:12
tilføj bruger fejl MOD's og Elementer 8 10-09-2015 20:59
Fejl under import af sql database Generel debat 2 24-06-2015 14:15
Opgradering af gammel php fusion installation Generel debat 4 24-03-2015 11:09